Java 8 support for Fall 2014?

 Here at UVa we're moving up to Java 8 this fall, and we were wondering if the Java compiler and tools used by Web-CAT would work with Java 8 this fall?

Thanks,

Tom Horton
horton@virginia.edu

Groups:

Comments

Stephen Edwards

Java 8 is now supported

Java 8 is fully supported on VT's server, as of the server upgrade earlier this month.  Sorry it took so long!

Stephen Edwards

We had the same request

We had the same request earlier this summer. Switching the Java compiler is easy, but the problem is the Checkstyle, PMD, and JaCoCo versions available at the start of summer were not yet upgraded for Java 8 (at least not all of them).

Now, they all have Java 8 support, and we plan to switch to Java 8 this fall. I've gotten some examples from instructors who wanted to use Java 8 for testing on one of our development machines.

So, the bottom line is that we hope to have it ready soon (in fact--hopefully by next week) ...